Архив рубрики: Без рубрики

1С8 Ошибка разыменования схемы XML. Почему? Есть ответ… все дело в атрибуте xmlns:xs

Я через сервис в интернете сгенерировал схему XSD и пытался ее загрузить в 1С объект:

Continue reading “1С8 Ошибка разыменования схемы XML. Почему? Есть ответ… все дело в атрибуте xmlns:xs” »

как минимизировать по-настоящему CSS и почему purify не подходит

результаты работы по исключению не используемых классов из CSS файла

Когда я пишу сайты я пользуюсь CSS SCSS(SASS) — мне больше нравится синтаксис SCSS. Потом естественно при записи Gulp отслеживает изменения *.scss файлов и генерирует CSS. Конечно при генерации я делаю циклы и миксины, чтобы было всё удобное под рукой. Отсюда и минус — в одном проекте классы нужны, в другом нет, а пишу я универсальные, чтобы использовать повторно. И даже в рамках одного проекта бывает что пока подбираешь верстку используешь то одни классы, то другие, но все они генерируются по одному алгоритму.

Continue reading “как минимизировать по-настоящему CSS и почему purify не подходит” »

твсРаботаСФайлами модуль 1с8

Функция ПолучитьРасширениеФайла(стрИмяФайла) Экспорт
	
	стрРасширениеФайла = "";
	
	ПозицияТочки = СтрДлина(стрИмяФайла);
	Пока ПозицияТочки >= 1 Цикл
		Если Сред(стрИмяФайла, ПозицияТочки, 1) = "." Тогда
			стрРасширениеФайла = Сред(стрИмяФайла, ПозицияТочки + 1);
			Прервать;
		КонецЕсли;
		ПозицияТочки = ПозицияТочки - 1;
	КонецЦикла;
	Возврат стрРасширениеФайла;
	
КонецФункции

Функция ВыбратьФайл(стрПолноеИмяФайла, Режим, Заголовок, Фильтр)
	
	Диалог = Новый ДиалогВыбораФайла(Режим);
	Диалог.Заголовок = Заголовок;
	Диалог.ПредварительныйПросмотр = Ложь;
	Диалог.Фильтр = Фильтр;
	
	Если ЗначениеЗаполнено(стрПолноеИмяФайла) Тогда
		Диалог.ПолноеИмяФайла= стрПолноеИмяФайла;
		стрИмяФайла = "";
		стрПутьКФайлу = "";
		РаботаСФайлами.ПолучитьКаталогИИмяФайла(стрПолноеИмяФайла, стрПутьКФайлу, стрИмяФайла);
		Диалог.Каталог = стрПутьКФайлу;
	КонецЕсли;
	
	Если Диалог.Выбрать() Тогда
		стрПолноеИмяФайла = Диалог.ПолноеИмяФайла;
		Возврат Истина;
	Иначе
		Возврат Ложь;
	КонецЕсли;
	
КонецФункции

// Открывает диалог выбора файла
//
// Параметры:
// стрИмяФайла - Строка - Полный путь к файлу
// Режим - РежимОткрытияФайла- (на запись, на чтение, на дозапись...)
// стрЗаголовок - Заголовок окна выбора файла
// Фильтр - маска фильтрации файлов в диалоге выбора файла
//
// Возвращаемое значение:
// нет
//
Функция ВыборИмениФайла(стрИмяФайла, Режим, стрЗаголовок = "", Фильтр = "*.*") Экспорт
	
	флВозврата = Ложь;
	СтандартнаяОбработка= Ложь;
	если Не ВыбратьФайл(стрИмяФайла, Режим, стрЗаголовок, Фильтр) тогда
		флВозврата = Ложь;
	Иначе
		флВозврата = Истина;
	КонецЕсли;
	Возврат флВозврата;
	
КонецФункции


// Проверяет по полному пути файла его существование
//
// Параметры:
// Параметр1 - Строка - Полный путь к файлу
//
// Возвращаемое значение:
// <Булево> - Возвращает Истина если файл существует
//
Функция ПроверитьСуществованиеФайла(стрПолнПутьКФайлу) Экспорт
	
	ФайлДляПроверки = Новый Файл(стрПолнПутьКФайлу);
	
	Возврат ФайлДляПроверки.Существует();
	
	
КонецФункции // ПроверитьСуществованиеФайла()

Функция СохранитьТекстВоВременныйФайл(стрТекст, стрРасширениеФайла, кодировкаФайла = "") Экспорт
	
	ЗагружаемыйФайл = Новый ТекстовыйДокумент;
	файлXML = Новый ЧтениеXML;
	
	ЗагружаемыйФайл.ДобавитьСтроку(стрТекст);
	
	стрИмяФайла = ПолучитьИмяВременногоФайла(стрРасширениеФайла);
	локКодировкаФайла = ?(кодировкаФайла = "", КодировкаТекста.UTF8, кодировкаФайла);
	ЗагружаемыйФайл.Записать(стрИмяФайла, локКодировкаФайла);
	
	Возврат стрИмяФайла;
	
КонецФункции //СохранитьТекстВоВременныйФайл()


Функция СохранитьURLВоВременныйФайл(знач стрURL, стрРасширениеФайла = "") Экспорт
	
	Если стрРасширениеФайла = "" Тогда
		стрРасширениеФайла = ПолучитьРасширениеФайла(стрURL);
	КонецЕсли;
	стрИмяФайла = ПолучитьИмяВременногоФайла(стрРасширениеФайла);
	стрСервер = твсРаботаСИнтернетом.ПолучитьСерверИзURL(стрURL);
	
	локПрокси = твсРаботаСИнтернетом.ПолучитьПрокси();
	Соединение = Новый HTTPСоединение(стрСервер,,локПрокси);
	
	HTTP_Запрос = твсРаботаСИнтернетом.СформироватьHTTPЗапрос(стрURL);
	Состояние("Загрузка: " + стрURL);
	
	Попытка
		HTTP_Ответ = Соединение.Получить(HTTP_Запрос, стрИмяФайла);
	Исключение
		Сообщить("Ошибка получения данных из Интернета по адресу: " + стрURL);
	КонецПопытки;
	
	Попытка
		Если HTTP_Ответ.КодСостояния >= 400 Тогда
			Сообщить("Код ответа сервера: " + HTTP_Ответ.КодСостояния + ". Ошибка получения данных из Интернета по адресу: " + стрURL);
			стрИмяФайла = "";
		КонецЕсли;
	Исключение
		Сообщить("Ответ не получен по адресу: " + стрURL);
	КонецПопытки;
	
	Возврат стрИмяФайла;
	
КонецФункции // СохранитьURLВоВременныйФайл()


Установка OpenOffice CD диск

Как OpenOffice Calс удалить лишние символы из телефонного номера?

формула в OpenOffice Calc удалить символы из строки в ячейке
=STRING_FUNCTION(B4;»-«;»»)
из 8-999-999-99-99 сделать 89999999999

=REPLACE(REPLACE(REPLACE(REPLACE(B3;2;1;»»);5;1;»»);8;1;»»);10;1;»»)

 

как запускать windows программы на Linux

как запускать Windows программы в Linux на примере дистрибутивов Debian, Ubuntu, Pepermint, Mint, Kubuntu, Lubuntu?

для того, чтобы windows программы работали в Linux нужно установить программу Wine. В Debian-дистрибутивах Linux это делается так:

вставить вот это в консоль Linux:
sudo apt-get install wine

затем просто запускаете установщик Windows программы как обычный файл и он работает.

Бывает так, что необходимы дополнительные файлы для работы Windows программы. Их легко найти через поисковую систему введя полное название файла и слово скачать.

Для устранения замешательства отмечу, что существуют платные и бесплатные продукты Wine. Указанный способ полностью легален и если у вас нет времени разбираться с лицензионной политикой linux и подобных ему свободно распространяемых программ то просто используйте указанный мной метод установки.

Детали в ниже в скрытом блоке.

Детали о том, почему эта программа обязана быть бесплатно доступной

Дело в том, что по скольку wine бы разработан с использованием технологий сообщества GNU General Public License, а Цель GNU GPL — предоставить пользователю права копировать, модифицировать и распространять (в том числе на коммерческой основе) программы, а также гарантировать, что и пользователи всех производных программ получат вышеперечисленные права

более подробно о Wine на русском (там предлагается платный продукт, но есть и много полезной информации.

как установить MC (Mindnight Commander) в CentOS, OpenSuse?

Mindnight Commander — это двухпанельный консольный менеджер файлов для Linux, xxxBSD систем. Очень удобен в работе. Стоит поставить на сервере, если пока работа с командной строкой для вас проблема (получается не очень быстро).

вставить вот это в консоль Linux:
yum install mc

Если Google Chrome не устанавливается из пакета с офф сайта Google

Внимание! Официальный способ установки от Google у меня он не создает значков в главном меню и google Chrome невозможно после этого запустить.

Ниже указанное решение у меня работает на 100?%

Решение:

открыть консоль и скопировать туда поочереди следующие команды:

вставить вот это в консоль Linux:

su

echo -e ‘Google Chrome«\n«‘deb http://dl.google.com/linux/chrome/deb/ stable main’ > /etc/apt/sources.list.d/google-chrome.list

wget -q -O — https://dl-ssl.google.com/linux/linux_signing_key.pub | apt-key add

apt-get update

apt-get install google-chrome-stable

если что-то не заработало для проверки введите в консоль:

вставить вот это в консоль Linux:

apt-cache search google-chrome

увидите доступные пакеты Google Chrome.

Почему в Linux клик по тачпаду не работает?

(одиночный клик по тачпаду вместо одиночного клика мышкой)

Я поставил себе linux Mint v 17 и столкнулся с тем, что тачпад (панель заменяющая мышку на ноутбуке) не реагирует на одиночное или двойное касание тачпада (что в Windows обычно заменяет клик (нажатие) левой кнопкой мыши (один или два раза в зависимости от количества коротких касаний тачпада пальцем).

Как это устранить? Ответ — не настроен тачпад. Настроки здесь:

Открыть Системные настройки — Мышь и сенсорная панель — Закладка «Сенсорная панель» — поставить крестик в «Включить нажатия мыши для сенсорной панели».

Снимок экрана от 2015-02-02 23:07:53Снимок экрана от 2015-02-02 23:08:07

Какие виды конденсаторов бывают?

произоводитель Jamicon:

Серия TKR конденсаторов — это конденсаторы общего применения с радиальным расположением гибких выводов и рабочей температурой до +105°С

Серия Конденсаторов HP — жесткие выводы, высокие импульсные токи, наработка на отказ 2000 часов при 105°C

Серия Конденсаторов  HS — уменьшенный размер по сравнению с серией HP, жесткие выводы, высокие импульсные токи, наработка на отказ 2000 часов при 105°C

 производитель CapXon:

Наработка на отказ 2000 часов при 105°C, стандартный размер, используются в устройствах повышенной надежности

производитель Samwa:

Алюминиевые электролитические конденсаторы высокотемпературные радиального типа серии RD повышенной надежности.

Как исправить ошибки в 1C 83 (1C v8.3)

вот статья 

копия статьи:

Использование утилиты chdbfl для тестирования и исправления физической целостности базы 1С:Бухгалтерия (8.3 редакция 3.0)

Статья устарела и требует переработки?

Если в процессе работы в 1С:Бухгалтерия (8.3 редакция 3.0) возникают странные ошибки или она вообще перестала запускаться — базу нужно чинить.

И, если вы уже попробовали сделать тестирование и исправление базы через конфигуратор, но это не помогло, то данная заметка для вас.

1. Для начала сделайте резервную копию имеющейся базы. Дело в том, что тестирование и исправление это необратимые операции над базой данных, которые почти всегда делают ситуацию лучше, но в очень небольшом проценте случаев могут все испортить. Вот на этот самый редкий случай мы и должны сначала сделать резервную копию.

2. Зайдите в папку, в которую у вас установлена 1С. Обычно это ‘C:\Program Files\1cv8’. Здесь вы увидите папки в названии которых присутствуют цифры, обозначающие номера версий платформы. Выберите папку с самой старшей версией (в нашем случае 8.3.4.304):

01

3. Внутри этой папки вы найдете папку bin:

02

4. Зайдите в эту папку. Там много файлов. Найдите файл с названием chdbfl:

03

5. Запустите этот файл и перед вами откроется утилита для проверки физической целостности файла базы данных.  Укажите имя файла базы данных, нажав кнопку с тремя точками:

04

6. Чтобы указать это имя зайдите внутрь папки той базы, которая не запускается и выберите там файл ‘1Cv8’:

05

7. Поставьте галку ‘Исправлять обнаруженные ошибки’. Бояться нечего, ведь у нас есть резервная копия. И нажмите кнопку ‘Выполнить’:

06

8. В зависимости от размера базы — проверка и исправление могут занять продолжительное время. Дождитесь окончания, закройте утилиту и запускайте базу — скорее всего она заработает.

07

С уважением, Алексей Карманов.

Отзыв о приборе для измерения RLC Mastech MS5308 LCR tester

Несколько дней назад я с товарищем выбирал себе прибор для измерения RLC  в частности интересовали параметры ESR и полного сопротивления при прохождении тока.

В результате пришел к выбору прибора:

http://grunekraft.com/prybory-raznie/RLC-meter-Mastech-MS-5308-izmeritel-immitansa-ESR-DCR

купил же прибор я в этом магазине (testers.ru). Продают в Москве. Деньги за эту «рекламу» готов принять от testers.ru — пишите в комментарии.

Как только узнаю о лучших предложениях — изменю ссылки. Пока таких не нашел.

почему рекомендую эту ссылку — мне понравилась цена и профессиональный подход к сайту, когда даются 2 инструкции. На русском и на английском языках плюс драйвера.

В комплекте с прибором идет диск с драйвером и инструкция на русском языке, но она с ошибками.

Так вот, это потрясающий прибор, который позволяет полностью проанализировать RC цепочку и весь колебательный контур. Позволяет определить какие параметры у катушки и конденсаторов. Было у меня такое, что емкость конденсаторов заявленная производителем, сопротивление тоже в норме, однако работают только несколько раз, а дальше резко падает выдаваемое напряжение.

С этим прибором я узнал что ESR у этих конденсаторов в 3 раза больше чем у новых. Очень полезно. В прибор встроен генератор сигналов. Можно узнать параметры детали или цепи на разных частотах. Далее  можно подключить к цепи осциллограф и посмотреть визуально что происходит в цепи.

как в консоли Linux определить свободное место на диске

узнать свободное место на диске

df -ah

эта команда выводит подробные сведения о свободном и занятом месте в файловой системе Linux (на жестких дисках, флешках…)

смена пароля пользователя SAMBA через консоль (например, для SSH подключения через Putty)

чтобы сменить пароль пользователя нужно вызвать команду:

smbpasswd

она без параметров меняет пароль для текущего пользователя .

следующая команда может быть выполнена только от суперпользователя (root) и стирает пароль у указанного пользователя, устанавливая пустой пароль.


sudo smbpasswd -n samba-user-name

 

&nbsp;

echo «Здравствуйте «$var_user_name» «
$SETCOLOR_RED
echo «Сейчас перед вами появиться поле для ввода нового пароля»
sudo smbpasswd $var_user_name
$SETCOLOR_NORMAL
echo «Нажмите любую клавишу для выхода»
read user_input
zero=0
if [[ $user_input -eq 0 ]];
then
exit 0
fi

[/bash]

Детали по теме базовое обучение: awk синтаксис, Awk команды, Awk скрипты, BASH скрипты

\t — означает символ табуляции

[] — обозначение множества символов (в регулярных выражениях) AWK работает с регулярными выражениями в подстроках поиска [:digit:] — множество символов, написано, что является аналогом множества символов: [0-9]

^ — в регулярном выражении означает отрицание

Знак доллара — $ — в конце регулярного выражения соответствует концу строки.

«^$» соответствует пустой строке.

«[xyz]» — один из перечисленных символов x, y или z.

«[c-n]» один из символов в диапазоне от c до n, включительно.

«[B-Pk-y]» — один любойсимвол в диапазоне от B до P или в диапазоне от k до y, включительно.

«[a-z0-9]» — один из символов латиницы в нижнем регистре или цифра.

«[^b-d]» — любой символ, кроме символов из диапазона от b до d, включительно. В данном случае, метасимвол ^ означает отрицание.

Если объединить выражения в квадратных скобках в одну последовательность, можно задать необходимое для поиска выражение. Например, выражение «[Yy][Ee][Ss]» соответствует словам yes, Yes, YES, yEs и так далее. Выражение «[0-9][0-9][0-9]-[0-9][0-9]-[0-9][0-9][0-9][0-9]» определяет шаблон для поиска любого номера карточки социального страхования (для США).

 

 

Где находится лежит файл лицензии 1С v8?

Где в 1С лежат файлы лицензии. Возник у меня этот вопрос т.к. Нужно было переносить 1С на другую ОС в пределах одной машины, а активаций ограниченное количество.
нашел статью http://webhamster.ru/mytetrashare/index/mtb0/1334038461vnr5weg73u

где автор описывает куда копать:

Файл однопользовательской лицензии лежит в каталоге: C:\Documents and Settings\All Users\1C\1Cv82\conf

или в каталоге: C:\ProgramData\1C\1Cv82\conf

файл называется примерно так:  20120302155201.lic

Если 1С пишет «Ключ защиты не обнаружен ….» То проблема решается так:

Проблема решилась копированием файла лицензии (она по умолчанию сразу попала в каталог:»C:\Users\All Users\1C\1Cv82\conf\2*.lic») в каталог:  C:\Program Files (x86)\1cv82\conf\

Если используются программная лицензия на сервер 1С-64x и многопользовательские лицензии лучше сразу отредактировать файлы:

C:\Program Files (x86)\1cv82\8.2.##.###\bin\conf\conf.cfg

C:\Program Files\1cv82\8.2.##.###\bin\conf\conf.cfg

указав один и тот же путь к программным лицензям, например:

ConfLocation=C:\Program Files\1cv82\conf

и в этот каталог положить обе лицензии.

Без этого на платформе 8.2.15 периодически наблюдались траблы типа: лицензию на сервер вижу, а много пользовательские не вижу.

Из всех других файлы лицензий убрать — иначе возможна ситуация когда 1С сама допишет файл лицензии текстом:

«На компьютере *** используются две копии одного и того же файла программной лицензии: file://C:/Program Files/1cv82/conf/2*.lic и file://C:/Program Files (x86)/1cv82/8.2.15.289/bin/conf/2*.lic»

 

SAMBA, LDAP

nmblookup (NetBIOS name query tool)

nmblookup (NetBIOS name query tool)

nmblookup

— Клиент NetBIOS поверх TCP/IP, используется для разрешения имен NetBIOS.

Утилита часть пакета

samba(7)

.

nmblookup

передает в запросе имя NetBIOS и преобразует его в IP адрес в сетях, использующих запросы NetBIOS поверх TCP/IP. Запросы болжны направляться широковещательно к области IP или к конкретному компьютеру. Все запросы выполняются поверх UDP.

 http://linuxdoc.ru/nsswitch-conf.html

nsswitch.conf — конфигурационный файл cистемных баз данных и переключателя сервисов имен

НАЗВАНИЕ
nsswitch.conf — конфигурационный файл cистемных баз данных
и переключателя сервисов имен

ОПИСАНИЕ
Многие функции в бибилиотеках C должны быть настроены так,
чтобы без сбоев работать в локальной среде. Раньше это
делалось с помощью соответствующих файлов (например,
`/etc/passwd’), но потом появились другие сервисы имен
(такие, как Network Information Service (NIS) и Domain
Name Service (DNS)), ставшие популярными и включенные в
библиотеки C.