Рубрики
1С: Предприятие 8.х Программирование

как открыть обработку в основном окне 1С: Предприятия (УФ) на Управляемых формах

&НаСервере
Функция ПодключитьПолучитьИмяВнешнейОбработки(Адрес)
    Защита = Новый ОписаниеЗащитыОтОпасныхДействий;
    Защита.ПредупреждатьОбОпасныхДействиях = Ложь;
    
    Результат = ВнешниеОбработки.Подключить(Адрес, , Ложь, Защита);
    
    Возврат Результат;    	
КонецФункции

Адрес = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ПолныйПутьВнешнейОбработки));
ИмяОбработки = ПодключитьПолучитьИмяВнешнейОбработки(Адрес);
ВсеОткрытыеОкна = ПолучитьОкна();
Для Каждого ОткрытоеОкно Из ВсеОткрытыеОкна Цикл
    Если ОткрытоеОкно.Основное Или ОткрытоеОкно.НачальнаяСтраница Тогда
        ОкноДляОткрытия = ОткрытоеОкно;
        Прервать;
    КонецЕсли;
КонецЦикла;
ОткрытаяФорма = ОткрытьФорму("ВнешняяОбработка." + ИмяОбработки + ".Форма.УФ_Форма",,,, ОкноДляОткрытия);

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.