Рубрики
1С: Предприятие 8.х Программирование

как получить форму внешней обработки на УФ в 1С: Предприятии

&НаСервере
Функция ПодключитьПолучитьИмяВнешнейОбработки(Адрес)
    Защита = Новый ОписаниеЗащитыОтОпасныхДействий;
    Защита.ПредупреждатьОбОпасныхДействиях = Ложь;
    
    Результат = ВнешниеОбработки.Подключить(Адрес, , Ложь, Защита);
    
    Возврат Результат;    	
КонецФункции

Адрес = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ПолныйПутьКОбработке));
ИмяСКоторымПодключенаОбработка= ПодключитьПолучитьИмяВнешнейОбработки(Адрес);
ВсеОткрытыеОкна = ПолучитьОкна();
Для Каждого ОткрытоеОкно Из ВсеОткрытыеОкна Цикл
        Если ОткрытоеОкно.Основное Или ОткрытоеОкно.НачальнаяСтраница Тогда
            ОкноДляОткрытия = ОткрытоеОкно;
            Прервать;
        КонецЕсли;
    КонецЦикла;

ФормаВнешнейОбработки = ПолучитьФорму("ВнешняяОбработка." + ИмяСКоторымПодключенаОбработка + ".Форма.ИмяФормы",,,, ОкноДляОткрытия);

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.