Рубрики
1С: Предприятие 8.х

Как проверить наличие данных в сложных объектах 1С

<code>Функция СодержитДанные(ЗначениеДляПроверки) Экспорт
    Результат = Ложь;
    
    Если ЗначениеДляПроверки &lt;> Неопределено Тогда
        Если ТипЗнч(ЗначениеДляПроверки) = Тип("ТаблицаЗначений")
            Или ТипЗнч(ЗначениеДляПроверки) = Тип("Массив") 
            Или ТипЗнч(ЗначениеДляПроверки) = Тип("СписокЗначений") 
            Тогда
            
            Если ЗначениеДляПроверки.Количество() > 0 Тогда
                Результат = Истина;
            КонецЕсли;
            
	Иначе
	    Результат = ЗначениеЗаполнено(ЗначениеДляПроверки);
        КонецЕсли;
    КонецЕсли;
    
    Возврат Результат;
КонецФункции </code>

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *