Рубрики
1С: Предприятие 8.х Запросы

Пустой запрос 1С

Выяснить содержимое запроса в 1С можно обратившись к результату запроса:

<code>РезультатЗапроса = Запрос.Выполнить();
Возврат НЕ РезультатЗапроса.Пустой();</code>

Согласно методическим рекомендациям сайта ITS 1C данную проверку при обработке рекордсета (выборки запроса) делать не нужно. Это признается избыточным. Просто дейлайте так:

<code>ВыборкаЗапроса = Запрос.Выполнить().Выбрать();
Пока ВыборкаЗапроса.Следующий() Цикл
//...обработчик выборки запроса
КонецЦикла;</code>

либо если Вам нужно изменить режим обхода выборки или обращаться к полям результата запроса или делать что-либо еще то:

<code>РезультатЗапроса = Запрос.Выполнить();
КолонкиЗапроса = РезультатЗапроса.Колонки;
Если КолонкиЗапроса.Найти("Остаток") = Неопределено Тогда
    Сообщить("Запрос не содержит колонки Остаток");
КонецЕсли;

ВыборкаЗапроса = РезультатЗапроса.Выбрать();

Пока ВыборкаЗапроса.Следующий() Цикл
//...обработчик выборки запроса
КонецЦикла;</code>

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *